IIJmioひかりを契約してみた(後編)

前編、中編とお届けしてきたプロバイダの契約変更ですが今回はその最終回DS-LiteへのRouterの設定変更です。

前回までのおさらい

我が家のInternet回線はNTT東日本のB-Flet’sを足回りとして使用しており、プロバイダはOCNとなっていました。回線契約は100Mbps。

PPPoEを使用したInternet回線は回線スピードとしては混雑時には数Mbps程度に落ち込むことが多くストレスに感じることが多くありました。

まずは、IIJmioひかりにプロバイダを変更し、それに合わせて回線スピードを100Mbpsから1Gbpsへと変更を行いました。

Gigabit化に伴い200Mオーバーの数値を出すことに成功しましたが、やはりPPPoEの制約で回線速度は混雑時には満足しないこともあるようです。

PPPoE(IPv4)からIPoE(IPv6)へ設定変更

RouterのPPPoEの設定を削除しIPoEによるIPv6の設定(IPv6パススルー:ブリッジ)をおこないます。

IIJmioのIPv6によるスピードテストを行ってみました。

完璧です。300Mを超えた数値をコンスタントに出すことに成功しました。IPv6はPPPoEの制限を受けなくなりましたのでIPv6に対応したサイトへのアクセスは何らストレスを感じることなく行うことが出来るようになりました。

とは言え、IPv6に対応したサイトはいまだ限定的で皆さんが日常的にアクセスされるサイトとしてはYoutubeぐらいなものでは無いでしょうか?

問題はIPv4に関してです。RouterにDS-Liteの設定を行うことによって改善することに期待が高まります。

DS-Liteの設定を行ってみたが。。

では早速DS-Liteの設定をし、回線スピード測定です。

おっと、もう少し早い数値を期待していたのですが40Mbps弱の結果です。。しかし混雑時においても30Mを下回る数値は無く安定したスピードが出ているようです。

IPv6通信は300M強出ていることを考えれば、IPv4は1/10のスピードとなるのは納得いかないですが、これはInternet Multifeed社の設備の問題という事なのでしょう。

とは言え、スピードが極端に落ちることも無く安定しているのでAbemaTVの視聴等何ら問題が無く行えているので概ね満足する結果となりました。

サンプルコンフィグ

今回使用したRouterはCiscoのCisco800シリーズとなっています。インターネット上に今回の構成にマッチしたコンフィグが無かったので掲載しておきます。

clock timezone JST 9 0
!
ip dhcp pool DHCP
network 192.168.xx.0 255.255.255.0
default-router 192.168.xx.1
dns-server 8.8.8.8
!
!
!
ip domain list flets-east.jp
ip domain list iptvf.jp
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip inspect name CBAC tcp
ip inspect name CBAC udp
ip inspect name CBAC icmp
ip inspect name CBAC ftp
ip cef
ipv6 unicast-routing
ipv6 cef
ipv6 inspect name IPV6INSPECT tcp
ipv6 inspect name IPV6INSPECT udp
ipv6 inspect name IPV6INSPECT icmp
ipv6 inspect name IPV6INSPECT ftp
!
bridge irb
!
interface Tunnel0
description To:MF
ip address 192.0.0.2 255.255.255.248
ip inspect CBAC out
tunnel source BVI1
tunnel mode ipv6
tunnel destination 2404:8E00::FEED:100
!
interface GigabitEthernet0/5
no ip address
duplex auto
speed auto
ipv6 inspect IPV6INSPECT out
bridge-group 1
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 input-type-list 200
!
interface BVI1
ip address 192.168.xx.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ipv6 address autoconfig default
ipv6 enable
!
ip route 0.0.0.0 0.0.0.0 Tunnel0
!
access-list 1 permit 192.168.xx.0 0.0.0.255
access-list 200 permit 0x86DD 0x0000
access-list 200 permit 0x0800 0x0000
access-list 200 permit 0x0806 0x0000
!
bridge 1 protocol ieee
bridge 1 route ip
!
line vty 0 4
access-class 1 in
login
transport input all
!
ntp server 210.173.160.57
ntp server 210.173.160.27
ntp server 210.173.160.87
!
end

関連記事

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

この記事のトラックバック用URL